Fortress siege bug?

I have tried to take one fortress. Killed all officers including that one on top, but fort gate is still closed? Am I doing something wrong?

Greetings, dear friend

Would you please be so kind to tell me which Fortress it was?

I know there’s some Fortresses that are tricky to siege and require you to do something with some NPCs, like dwarfs and such - I don’t remember exactly the names

Thank you!
Best regards

I did bayou and later on antharas with same result.

I noticed that there were extra npc’s and an extra room, but I can’t remember what they were called. They were in both bayou and antharas. At bayou I didn’t do anything with them, but in antharas I did as below.

The three npc’s around the room were of the A, B, C, D, E letter selection with 4 tries? Each npc disappeared after 4 tries. When these three npc disappeared then you could open the front door with the npc that stood in front of the door. Inside there were another 3 npc’s for typing in some four-number pins - once you typed in any combination the npc’s would disappear. Apart from the chat messages there was no effect and the fort gate was further closed.

This was the first time I’ve encountered something like this, and I’ve taken over fortresses in h5 hundreds of times. It must be some mechanic from later chronicles.

Today if I still have time to log in I will try to take over the fortress again and give the npc names.

1 Like

Thank you for the detailed report!

I’ll be trying some Fortress Sieges myself too, let’s see if I find something :slight_smile:

I found some tutorial here:

Unfortunately, I no longer have a way to test it, as the beta has ended. It doesn’t look too complicated, but it needs to be tested.

During the beta I saw that the PK clan took over Hunters fortress, so unless some hacks were used here it should be possible to take over the fort.